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1. Introduction 

Overview 
Moxa has pioneered the concept of “active type” OPC software in the automation industry. The patented 
MX-AOPC UA Server offers both polling (Modbus protocol) and non-polling (Moxa AOPC protocol) 
architectures alongside the standard OPC UA protocol, giving users the alternative of pull or push-based 
communication from Moxa’s devices. OPC UA (Unified Architecture), which features more secure and reliable 
data communication between OPC servers and clients, is the next generation OPC standard (IEC 62541). By 
using Moxa’s MX-AOPC UA Server, users can enjoy more secure and reliable data exchange and control. 

The MX-AOPC UA Server includes: 

• Server Runtime Service: Starts as a service by default after installation. 

• Configuration Console: An offline configuration tool for configuring server settings. 

• Viewer: An OPC client that allows developers, testers, and integrators to easily view tag values and 
test MX-AOPC UA Server and connections. 

System Requirements 
Hardware Requirements 
CPU: Intel Pentium 4 or above 
RAM: 512 MB (1024 MB or higher is recommended) 
Communication Interface: Ethernet or serial 
 Software Requirements 
Operating System: Microsoft Windows 7/8/10/11, Microsoft Windows Server 
2003/2008/2012/2016/2019/2022 
Microsoft .NET Framework: v3.5 Service Pack 1 
Editor (optional): Microsoft Office 2003 Excel or later 

Specifications 
OPC Server Specifications 
OPC Unified Architecture: 1.02 
OPC Data Access: 1.0a, 2.0, 2.05a, 3.0 
Device Protocols: Moxa AOPC, Modbus/TCP (master), Modbus/RTU (master) 
 Products that Support AOPC Protocol 
ioLogik: ioLogik 2500 Series, ioLogik E1200 Series, ioLogik E1500 Series, ioLogik E2200 Series, ioLogik 
E4200, ioLogik W5300 Series, ioPAC 8500 Series, ioPAC 8600 Series 
Note: Please check Moxa’s website for the most up-to-date list of supported products. 
Fully Supported OPC UA Server Profiles 
Standard UA Server Profile 
Core Server Facet 
• User Token: User Name Password Server Facet 
• SecurityPolicy: None 
Data Access Server Facet 
UA-TCP UA-SC UA Binary 
User Token: X509 Certificate Server Facet 
SecurityPolicy: Basic128Rsa15 
SecurityPolicy: Basic256Sha256 
SecurityPolicy: None 
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2. Getting Started 

Installing MX-AOPC UA Server 
MX-AOPC UA Server can be downloaded from the Moxa website at www.moxa.com. 

After downloading the file, unzip it and run setup.exe. The installation program will guide you through the 
MX-AOPC UA Server installation process. 

Configuring Active Tags 
MX-AOPC UA Server will automatically receive active tags from Moxa’s remote devices through the Moxa 
AOPC protocol once the tags are created. Refer to the device’s user’s manual to learn how to use the 
device’s configuration utility to create active tags. 

Opening the Configuration Console 
Open MX-AOPC UA Server’s configuration console from the Windows Start menu: Start > All Programs > 
MOXA > IO Server > MX-AOPC UA Suite > MX-AOPC UA Server. 

Select main network adapter the first time you open the configuration console. 

 

  



 

 

MX-AOPC UA Server User Manual 6 

The configuration console is an offline configuration tool for configuring Server Runtime settings. When the 
configuration console is launched, it will automatically get the latest configurations from the Server 
Runtime. If any active tag is received, the device will be listed in the Active Device List. To manually get 
the latest configurations from the Server Runtime, click the Get Configuration from Server icon on the 
MX-AOPC UA Server menu bar. To manually update the settings to the Server Runtime, click the Update 
Configuration to Server icon on the menu bar. 

 

 NOTE 
 The first time you use MX-AOPC UA Server, we recommend turning off, or adding rules to, the Windows 

Firewall and then checking to see if MX-AOPC UA Server can receive active tags. If it can, turn the 
Windows Firewall back on and check it again. If MX-AOPC UA Server does not receive any active tags after 
you turn on the Windows Firewall, add aopcservice.exe in the Firewall Inbound Rules, and set it to Allow 
for Private, Public, and Domain network profiles. 

 

 NOTE 
 Be sure to update the settings to the Server Runtime after changing the configuration. Otherwise, the 

Server Runtime will not reflect the configuration changes made using the configuration console. 
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Configuring Server Settings 
Before configuring devices and tags, configure the server settings described below under the Tools menu. 

 

• Change Password 

We strongly recommend changing the password the first time you use the Configuration Console. The 
default password is “moxa”, which is needed for verification when updating configurations to the Server 
Runtime or exporting the system log to a text file. 

 NOTE 
 When connecting an OPC UA client to MX-AOPC UA Server, use account name “admin” (the account name 

cannot be changed) and whatever the password is. The password is the same as the system password, 
which can be updated using Tools > Change Password. 

 

• Serial Port Settings 

Configure the PC’s Serial Port Settings if a serial device is connected to MX-AOPC UA Server. 
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• AOPC Settings 

Configure AOPC Settings if a Moxa device updates Active Tags to MX-AOPC UA Server. 

 

Configuring Devices and Tags 

Adding a Modbus Device 

1. Click the Modbus Device Group List to select it and then click the New Device Group icon and type 
in the name of the device group. 
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2. Click the New Device icon and then configure the device properties. 

 
3. Click the device group you just created to display a list of the devices in this group. 
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Creating Modbus Tags 

1. Click the device name to select it and then click the New Tag Group icon and type in the name of the 
tag group. 

 
2. Click the New Tag icon and then configure the tag properties. 
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3. The tag will be listed in the tag group. 

 

Updating Configurations to the Server 
When you finish updating the configuration, click the Update Configuration to Server icon to update the 
configuration to the Server Runtime. When the Verify Password window pops up, enter the correct 
password and then click OK to activate the changes. 

 

Using the Viewer to Check Tag Values 
After completely updating the Server Runtime settings, click the Viewer icon to open the viewer to check 
that the tag value is correct. 
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The device tree in the left panel should be the same as the tree displayed by the configuration console. Click 
a tag group name to display the group’s tag values in the right panel. 

 

Configuring OPC UA Settings 
You should configure OPC UA settings before connecting an OPC UA client to MX-AOPC UA Server. To access 
OPC UA Settings options, click Tools ( OPC UA Settings. Instructions for each option are:. 
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• Server Endpoints Settings 

“Server Endpoints Settings” are a list of interfaces that UA clients can use to communicate with MX-
AOPC UA Server. MX-AOPC UA Server supports Universal Resource Locator (URL) binary type protocols. 

To add a new interface to the list, select the appropriate network interface in the Network Interface 
drop-down box and type the port number for the URL in the Port Number input box. Click Add to add 
this new server endpoint to the list. 

 
• Security Policy 

The security policy is applied to connections between OPC UA clients and MX-AOPC UA Server. Security 
options that can be selected are None, Basic128Rsa15: Sign, Basic128Rsa15: Sign and Encrypt, 
Basic256Sha256: Sign, or Basic256Sha256: Sign and Encrypt. Besides “None”, you will need to 
configure Certificates Management settings (see below). 

 

 NOTE 
 The default account and password for connecting an OPC UA client to the server are: 

  Account:  admin 
 Password: moxa 

 The account name cannot be changed. To change the password, click Tools > Change Password. 
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• Certificates Management 

When the security option is chosen, besides "None", importing an OPC UA client’s CA (Certificate 
Authority) file into MX-AOPC UA Server, and exporting the MX-AOPC UA Server’s CA file to OPC UA 
Clients are both required. 

Click the Trust Clients tab, click Import, and select the client’s CA file to import it into MX-AOPC UA 
Server. 

 

Click the Instance Certificates tab and click Export Server Certificate to export MX-AOPC UA 
Server’s CA file to OPC UA Clients. 

 

Click the Update Configuration to Server icon to enable any changes that have been made to the 
OPC UA configuration. 

 NOTE 
 After reissuing certificates or re-installing MX-AOPC UA Server, you will need to export the Server 

Certificate once again to OPC UA clients. 
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3. Configuration Console 

Main Screen Overview 
MX-AOPC UA Server’s configuration console displays the mapped I/O device with the settings of every I/O 
tag. It also shows the Server Runtime status and number of OPC clients. 

 

No. Zone Description 
1 Software Title Displays the name of the software: MX-AOPC UA Server 
2 Menu All configuration functions 
3 Quick Launch Bar Frequently used icons 
4 Device View All devices and tags 
5 Detailed View Detailed settings of the devices and tags 
6 Log View Server Runtime logs 
7 Server Runtime Status Shows if the Server Runtime Service is Running or Stopped 
8 Server Time Displays the server time (same as the PC’s time) 
9 Numbers of Device Displays the number of devices listed in Device View 
10 Numbers of OPC Client Displays the number of OPC clients connected to MX-AOPC UA Server 
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Menu Items 
All operations can be accessed from the following menu items. 

File 

Use the File menu to manage project files, device tags, and server configuration. 

 

• New: Create a new project file. 

• Open: Open an existing project file. 

• Save: Save the current project. 

• Save As: Save the current project file as another project with a different filename. 

• Import: 

 Ethernet Modbus Device (.csv): Import Ethernet Modbus devices into device groups from a csv file. 
Item Format Length Note 
DeviceGroupName 0 to 9, A to Z, a to z, Symbols 30 “.” is not allowed. 
DeviceName 0 to 9, A to Z, a to z, Symbols 30 “.” is not allowed. 
Enable 0: disable; 1: enable –  
CommunicationPort Network adapter name –  
DeviceID 1 to 247 –  
IPAddress xxx.xxx.xxx.xxx –  
Port 0 to 65535 –  
ReconnectDelay(ms) 0 to 30000 –  
ReconnectCycle 0 to 10 –  
CycleDelay(sec) 0 to 86400 –  
PollingTimeout(ms) 0 to 30000 –  
PollingRetries 0 to 10 –  
DelayBetweenPolls(ms) 100 to 3600000; 0 disabled –  
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 Serial Modbus Device (.csv): Import Serial Modbus devices into device groups from a csv file. 
Item Format Length Note 
DeviceGroupName 0 to 9, A to Z, a to z, Symbols 30 “.” is not allowed. 
DeviceName 0 to 9, A to Z, a to z, Symbols 30 “.” is not allowed. 
Enable 0: disable; 1: enable –  
CommunicationPort Serial port name –  
DeviceID 1 to 247 –  
ResponseTimeout(ms) 0 to 30000 –  
 

 Device Tags (.csv): Import device tags into a Modbus device from a csv file. 
Item Format Length Note 
GroupName 0 to 9, A to Z, a to z, Symbols 30 “.” is not allowed. 
TagName 0 to 9, A to Z, Symbols 30 “.” is not allowed. 

FunctionCode 1 to 4 – 

1: Read/Write Coils 
2: Read Discrete Inputs 
3: Read/Write Holding 
Registers 
4: Read Input Registers 

Address 0 to 65535 –  

DataType 

Boolean 
Unsigned short integer 
Unsigned integer 
Float 

– 

• Use Boolean with 
FunctionCode 1 or 2. 

• Use other DataTypes 
with FunctionCode 3 or 
4. 

Description 0 to 9, A to Z, a to z, Symbols 25  

TagQuantity 
1 to 2000 when function code is 1 or 2. 
1 to 125 when function code is 3 or 4. 

TagQuantity  

DataConversion 

None 
“LoByte & HiByte” (if Unsigned Short 
Integer is defined) 
“HiByte & LoByte” (if Unsigned Short 
Integer is defined) 
“LoWord & HiWord” (if Unsigned 
Integer or Float is defined) 
“HiWord & LoWord” (if Unsigned 
Integer or Float is defined) 

–  

StartNumber 0 to 99 –  

• Export: 

 Ethernet Modbus Device (.csv): Export Ethernet Modbus devices from device groups to a csv file. 

 Serial Modbus Device (.csv): Export Serial Modbus devices from device groups to a csv file. 

 Device Tags (.csv): Export device tags from a Modbus device to a csv file. 

• Get Configuration from Server: Get the latest configuration from the Server Runtime. 

• Update Configuration to Server: Update the configuration to the Server Runtime from the 
Configuration Console. 

• Previous saved files: Quickly open previously saved project files. 

• Exit: Close the Configuration Console. 

 NOTE 
 Active Tags cannot be imported into an Active Device folder in the Configuration Console from a csv file, or 

vice versa. Active Tags are automatically created by a Moxa active tag device. Refer to the Specifications 
section for the Products that Support AOPC Protocol, and refer to the device’s user’s manual to see 
how to create active tags using the device’s configuration utility. 

 

 NOTE 
 Execute the Export function to get a csv template. 
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Edit 

Use the Edit menu to edit settings of devices and tags. 

 

• Cut: Cut a tag group or selected tags. 

• Copy: Copy a tag group or selected tags. 

• Paste: Paste a cut or copied tag group into a device or paste cut or copied tags into a tag group. 

• Delete: Delete the selected device, a selected tag group, or selected tags. 

• Select All: Select all tags in a tag group. 

• New Device Group: Create a new device group. 

• New Device: Create a new Modbus device. 

• New Tag Group: Create a new tag group. 

• New Tag: Create a new tag. 

• Properties: Change the settings of an existing device group, device, tag group, or tag. 

 NOTE 
 The properties of an active device or active tag cannot be changed from the configuration console. Refer to 

the device’s user’s manual to see how to use the device’s configuration utility to change active device or 
active tag settings. 

 

View 

Use the View menu to change the display settings of the Device View panel. 

 

• Expand All Devices: Expand all devices in the Device View panel. 

• Collapse All Devices: Collapse all devices in the Device View panel. 
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Tools 

Use the Tools menu to configure serial ports, OPC settings, system log, password, console environment 
settings, or to launch Viewer. 

 

• Serial Port Settings 

 

 Baud Rate: 300 to 921600 bps; default: 115200 bps 

 Flow Control: None, RTS/CTS, or XON/XOFF; default: None 

 Data Bits: 5, 6, 7, or 8; default: 8 

 Stop Bits: 1 or 2; default: 1 

 Parity: Even, Odd, or None; default: None 
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• AOPC Settings 

 

 Default Network Interface: Select a network interface that remote devices can use to connect to 
MX-AOPC UA Server. 

 Active Tag Listen Port: The preferred TCP socket port for receiving active tags from remote 
devices (default: 9900). 

 Command Timeout: The socket timeout interval (Port: 9500 and 9900) for controlling output 
channels on remote devices: 0 to 60; default: 30 sec. 

 Heartbeat Tolerance: An additional timeout interval to wait for a heartbeat signal from remote 
devices: 0 to 60; default: 30 sec. 

 DCOM Configuration: Configure DCOM settings for your security policy. Refer to Appendix A for 
details. 

• OPC UA Settings 
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 Server Endpoints Settings: 

“Server Endpoints Settings” are a list of interfaces that UA clients can use to communicate with MX-
AOPC UA Server. MX-AOPC UA Server supports Universal Resource Locator (URL) binary type 
protocols. 

To add a new interface to the list, select the appropriate network interface in the Network 
Interface drop-down box and type the port number for the URL in the Port Number (default: 
53192) input box. Click Add to add this new server endpoint to the list. 

 
 Security Policy 

The security policy applies to connections between OPC UA clients and MX-AOPC UA Server. Security 
options that can be selected are None, Basic128Rsa15: Sign, Basic128Rsa15: Sign and 
Encrypt, Basic256Sha256: Sign, or Basic256Sha256: Sign and Encrypt. Besides “None”, you 
will need to configure Certificates Management settings (see below). 

 

 NOTE 
 The default Account and Password for connecting an OPC UA client to the server are: 

  Account:  admin 
 Password: moxa 

 The account name cannot be changed. To change the password, click Tools > Change Password. 
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 Certificates Management 

When the security option is chosen besides "None", importing an OPC UA client’s CA (Certificate 
Authority) file into MX-AOPC UA Server and exporting the MX-AOPC UA Server’s CA file to OPC UA 
Clients are both required. 

Click the Trust Clients tab, click Import, and select the client’s CA file to import it into MX-AOPC 
UA Server. 

 

Click the Instance Certificates tab and click Export Server Certificate to export MX-AOPC UA 
Server’s CA file to OPC UA Clients. 

 

Click the Update Configuration to Server icon to enable any changes that have been made to the 
OPC UA configuration. 

 NOTE 
 After reissuing certificates or re-installing MX-AOPC UA Server, you will need to export the Server 

Certificate once again to OPC UA clients. 
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• Viewer: Open the viewer to check that the tag value is correct. 

• System Log 

 
 Save to Text File: Save MX-AOPC UA Server’s system log to a text file. You will be required to 

enter a password (default password: moxa). 

 

 Reset System Log: Reset MX-AOPC UA Server’s system log. You will be required to enter a 
password (default password: moxa). 

      

 System Log Settings: Defines the maximum number of records that can be saved in the MX-AOPC 
UA Server’s system log: 1 to 30000; default: 30000. 
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• Change Password: Change the MX-AOPC UA Server’s system password. The password is required 
when updating configurations to System Runtime, saving system logs to a text file, or resetting system 
log. 

Length: 4 to 128; acceptable characters: A to Z, a to z, 0 to 9, Symbols; default: moxa. 

 

• Options: Configure environment settings for the server’s configuration console. 

 

 NOTE 
 If Automatically save configuration every xx min(s) is enabled, the configuration file will be 

automatically saved only when a file name is defined. Be sure to save your configuration file after creating 
a new project file. 
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Runtime 

Use the Runtime menu to Start, Stop, or Reinitialize Server Runtime Service. 

 

Help 

Use the Help menu to launch the server’s help documentation, to check the server’s license status, to add a 
license file, or check server version. 

 

• Server Help: Launch MX-AOPC UA Server’s help documentation. 

• Licensing 

 

 License Info: Displays the server’s User Code, License Status, and the Time Remaining on the 
license. Refer to Chapter 6: License Registration and Activation to learn how to activate the 
license. 
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 Add License File: Import a license file after completing the license registration process. Refer to 
Chapter 6: License Registration and Activation to learn how to activate the license. 

 Deactivate License: Deactivate the current paid license version and load factory default settings. 
Note that when you deactivate the license, your license file and runtime configurations will be 
deleted. Please backup your runtime configurations before executing a license deactivation 
procedure. 

• About: Displays MX-AOPC UA Server’s version number and build number. 
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4. Device Management 

Device Group 
In this section, we explain how to use the configuration console to add, edit, and delete device groups. 

MX-AOPC UA Server’s design logic is user-application oriented. As seen below, device groups can be created 
based on application, such as SiteA or SiteB. 

 

Adding a Device Group 

1. Right click Modbus Device Group List and then click New Device Group in the pop-up menu, or click 
Modbus Device Group List to select it, and then click the New Device Group icon on the Quick 
Launch toolbar. 
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2. Type in the name of the device group (max. length = 30 characters; “.” is not allowed), and then click 
OK. 

 

3. The new device group will be added to the Modbus Device Group List. 

 

Editing a Device Group 

Right click the device group you would like to edit and then click Properties in the pop-up menu, or click 
the device group to select it and then click the Properties icon on the Quick Launch toolbar to open the 
properties window. 
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Deleting a Device Group 

Right click the device group you would like to delete and then click Delete in the pop-up menu, or click the 
device group to select it and then click the Delete icon from the Quick Launch toolbar. 

 

Active Devices 
In this section we explain how to use the configuration console to delete active devices. 

MX-AOPC UA Server will automatically receive the registration from a Moxa active device at a remote site. 
Refer to the Moxa I/O device’s user’s manual to learn how to use the device’s configuration utility to create 
active tags. 

Deleting an Active Device from the Active Device Group List 

Right click the active device you would like to delete and then click Delete in the pop-up menu, or click the 
active device to select it and then click the Delete icon from the Quick Launch toolbar. 

 

 NOTE 
 After an active-device name is changed through the web console or configuration utility, delete the active 

device on the MX-AOPC UA Server and execute “Update Configuration to Server.” The change will take 
effect the next time the device creates active tags to the MX-AOPC UA Server. 
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Modbus Devices 
In this section, we explain how to use the configuration console to add, edit, delete, and move Modbus 
devices. 

Adding a Modbus Device to a Device Group 

Right click the device group you would like to add a new Modbus device to and then click New Device in 
the pop-up menu. You may instead click the device group to select it and then click the New Device icon 
on the Quick Launch toolbar. 

 

Ethernet Communication Port 
If an Ethernet communication port is selected, the Device Property configuration window will appear as 
shown below: 

 

• Device Name: Name of the Modbus device (max. length = 30; “.” is not allowed). 

• Enable Data Collection: Enable or disable data collection for this Modbus device. 

• Communication Port: Select the communication interface of this Modbus device. 
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• Device ID: The device ID of this Modbus device (options: 1 to 247). 

• IP Address: The IP Address of this Modbus device. 

• Port: The TCP port of this Modbus device (options: 0 to 65535). 

• Delay between Polling: The delay time after the server polls Modbus register(s) of this device 
(options: ms, 100 to 3600000; 0 disabled). 

• Reconnect Delay: The delay time after the server tries to reconnect this Modbus device (options: 0 to 
30000; default: 3000). 

• Reconnect Cycles: The maximum number of reconnect cycles (options: 0 to 10; default: 3). 

• Cycle Delay: The delay time after reaching the maximum number of reconnect cycles (options: 0 to 
86400; default: 3). 

• Polling Timeout: The timeout value when the server polls data from this Modbus device (options: 0 to 
30000; default: 3000). 

• Polling Retries: The maximum number of retries after a polling timeout occurs (options: 0 to 10; 
default: 3). 

 

Serial Communication Port 
If a serial communication port is selected, the Device Property configuration window will appear as shown 
below: 

 

The following configuration items only appear when a serial communication port is selected. 

• Response Timeout: The timeout value when the server polls the data of this Modbus device (options: 
0 to 30000; default: 3000). 

• Polling Delay: The delay time after a polling timeout occurs (0 to 60000; default: 10). 
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The newly created device group will now be shown as belonging to this group. 

 

Importing a List of Modbus Devices into Device Groups 

Right click the Modbus Device Group List and then click Ethernet Modbus Device (.csv) or Serial 
Modbus Device (.csv) in the pop-up menu to import a list of Modbus devices into device groups. Select a 
csv file on your PC to import the devices listed in the csv file into the Device Groups. Refer to Chapter 3: 
Configuration Console ( Menu Items ( File for detailed csv file formats. 

 

Editing a Modbus Device 

Right click the Modbus device you would like to edit and then click Properties… in the pop-up menu, or 
click the Modbus device to select it and then click the Properties icon in the Quick Launch toolbar to open 
the properties configuration window. 
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 NOTE 
 You are not allowed to cut, copy, or paste a Modbus device. 
 

Deleting a Modbus Device 

Right click the Modbus device and then click Delete in the pop-up menu, or click the Modbus device to 
select it and then click the Delete icon in the Quick Launch toolbar. 

 

Moving a Modbus Device to a Different Device Group 

1. Right click the Modbus device and then click the target device group in the pop-up menu. 
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2. The Modbus device will be moved to the target device group. 
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5. Tag Management 

Tag Groups 
In this section, we explain how to use the configuration console to add, edit, cut, copy, paste, and delete 
tag groups. 

Adding a Tag Group to a Device 

1. Right click the device that the tag group will be added to and then click New Tag Group in the pop-up 
menu, or click the device to select it and then click the New Tag Group icon on the Quick Launch 
toolbar. 

 

2. Type in the name of the tag group (max. length = 30 characters; “.” is not allowed) and then click OK. 
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3. The new tag group will be added to the device. 

 

Editing a Tag Group 

Right click the tag group and then click Properties in the pop-up menu, or click the tag group to select it 
and then click the Properties icon on the Quick Launch toolbar. 
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Cutting a Tag Group 

Right click the tag group and click Cut in the pop-up menu, or click the tag group to select it and then click 
the Cut icon on the Quick Launch toolbar. 

 

Copying a Tag Group 

Right click the tag group and then click Copy in the pop-up menu, or click the tag group to select it and 
then click the Copy icon on the Quick Launch toolbar. 
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Pasting a Tag Group 

Right click the Tag Group and then click Paste in the pop-up menu, or click the tag group to select it and 
then click the Paste icon on the Quick Launch toolbar. 

 

Deleting a Tag Group 

Right click the tag group and then click Delete in the pop-up menu, or click the tag group to select it and 
then click the Delete icon on the Quick Launch toolbar. 
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Modbus Tags 
In this section we explain how to use the configuration console to add, edit, delete, and move a Modbus tag. 

Adding a Modbus Tag to a Tag Group 

1. Right click the tag group that the Modbus tag will be added to and then click New Tag in the pop-up 
menu, or click the tag group to select it and then click the New Tag icon on the Quick Launch toolbar. 

 

2. Edit the items in the Tag Property window as needed. 

 

 Function Code: Select the function code for this Modbus tag (options: 01: Read/Write Coils; 02: 
Read Discrete Inputs; 03: Read/Write Holding Registers; 04: Read Input Registers). 

 Address: Show Read/Write or Read-only attribute of this tag(s). 
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 Tag Name: The name of the Modbus tag (max. length = 30; “.” is not allowed). 

 Description: Description of this Modbus tag (max. length = 25). 

 Start Address: Define the start address of this Modbus tag (0 to 65535). 

 Coil Length / Register Length: Define the length of the coil (1 to 2000) or the register (1 to 125). 

 Data Type: Selecting the data type of this Modbus tag (options: Boolean; Unsigned short integer; 
Unsigned integer; Float). 

 Start Number: Define the start number of the continuous coils or registers. The continuous coils or 
registers will be divided into different tags with unique name based on this number definition. 

 Data Conversion: Define the sequence of the High/Low Bytes or Words for the register(s). 

 Tag Quantity: Show the quantity of the tag(s). 

3. Click the tag group to verify that the Modbus tag was added to this group. 

 

Importing a List of Modbus Tags into a Modbus Device 

To import a list of Modbus tags into a Modbus device, right click the Modbus device and then click Import 
Device Tags (.csv) in the pop-up menu. Select a csv file on your PC to import the tags listed in the csv file 
into the Modbus device. Refer to Chapter 3: Configuration Console ( Menu Items ( File for detailed csv 
file formats. 
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Editing a Modbus Tag 

Click the Modbus tag to select it and then click the Properties icon on the Quick Launch toolbar. 

 

Deleting a Modbus Tag 

Click the Modbus tag to select it and then click the Delete icon on the Quick Launch toolbar. 
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6. License Registration, Activation and 
Transfer 

Three versions of MX-AOPC UA Server are available. The trial version, which supports up to 30 connected 
devices, can be installed and used for 30 days without registration. To use the free and paid versions, you 
must submit a license registration. Both free and paid versions can be used indefinitely, but the free version 
only supports up to 30 connected devices. We summarize the three versions in the following table: 

Version Connected Devices Run Time License File 
Trial Up to 30 30 days Not Required 
Free Up to 30 Unlimited Required 
Paid Unlimited Unlimited Required 

License Registration and Activation 
Take the following steps to register a license. 

Step 1: Get the PC User Code from the MX-AOPC UA server’s configuration console by clicking Help > 
License. For the paid version, you will need to purchase a registration code from your Moxa 
distributor. The registration code will send to your email address. 
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Step 2: Go to Moxa's website (https://www.moxa.com) and log in with your Moxa account and password, 
or apply for an account if this is your first visit to the site. Navigate to Support > Software 
License Management to access the license portal. 

 
Step 3: On the Software Licensing website, navigate to Products and Licenses > Activate a Product 

License. Select MX-AOPC UA Server from Product Type, then select Free Version from Sub 
Product Type and enter the User Code or select Paid Version and enter both the User Code and 
Registration Code. 
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Step 4: Download the license file to a folder on your PC. 

 
Step 5: From MX-AOPC UA server’s configuration console, click Help > Licensing > Add License File to 

add the license file (.lic) to MX-AOPC UA Server. 
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Step 6: After license activation is complete, go to Help > License Info to check the current license 
status. 

    

 

License Transfer 
You can transfer the Paid License to another device. Take the following steps. 

Step 1: Back up your runtime configuration from File > Save / Save as. 

 

Step 2: From the MX-AOPC UA server’s configuration console, click Help > Licensing > Deactivate 
License. 
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Step 3: There will be a warning message and password protection before deactivation. 

 

 

Step 4: Get the deactivation code from the MX-AOPC UA server's configuration console by clicking Help > 
License > License Info. 

 

Step 5: Go to the Software License Management website, navigate to Products and Licenses > 
Transfer a Product License. 
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Step 6: Choose MX-AOPC UA Server in Product Type, pick the license to be transferred, enter the 
deactivation code and the new user code. A new license file will be available to download. 
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A. Appendix 

Port Usage 
Port Type Usage 
502 TCP Modbus Communication 
53192 TCP Default UA Server Endpoint 
9500 TCP Moxa AOPC protocol 
9900 TCP Moxa AOPC protocol 

Configuring DCOM Settings 
If the OPC client only supports the OPC Data Access (DA) standard, you will need to configure DCOM 
settings. Before launching MX-AOPC UA Server, configure the DCOM settings for your security policy. 

 NOTE 
 If the OPC Client and Server software are installed on different servers, the DCOM, WORKGROUP, System 

Account, and Password settings should be the same. 
 

1. Go to the START menu and type dcomcnfg to activate the Component Services dialog box. 

 
2. Right click My Computer under Console Root ( Component Services ( Computers, and click 

Properties to open the My Computer Properties dialog box. 
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3. Click the COM Security tab and edit who is allowed by default to access, launch, or activate the 
applications or objects. 
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4. Add Everyone, INTERACTIVE, NETWORK, and SYSTEM, and set Allow permission to these groups. 
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5. Click the Default Properties tab and check if the settings are the same as shown in the screenshot 
below. 

 

6. Click Yes when the following warning message appears. 
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7. Go back to the Component Services dialog box, and right click MOXA_ACTIVE_OPC_SERVER under 
Console Root ( Component Services ( Computers ( My Computer ( DCOM Config, and then click 
Properties. 

 
8. Click the General tab, and set the Authentication Level to Connect. 
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9. Click the Security tab. You may either apply the default settings of Access, Launch, and Activation 
Permissions to the MX-AOPC UA Server or customize the permission settings. If you would like to 
customize the settings, make sure that Everyone, INTERACTIVE, NETWORK, and SYSTEM are 
added, and the permission for these groups is set to Allow. 
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10. Click the Identity tab and make sure The system account is selected. Now DCOM is ready to accept 
all incoming connections. 

 

 


