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Introduction

The following topics are covered in this chapter:

O Overview
0O System Requirements
O Specifications



MX-AOPC UA Server Introduction

Overview

Moxa has pioneered the concept of “active type” OPC software in the automation industry. The patented
MX-AOPC UA Server offers both polling (Modbus protocol) and non-polling (Moxa AOPC protocol) architectures
alongside the standard OPC UA protocol, giving users the alternative of pull or push-based communication from
Moxa’s devices. OPC UA (Unified Architecture), which features more secure and reliable data communication
between OPC servers and clients, is the next generation OPC standard (IEC 62541). By using Moxa’s MX-AOPC
UA Server, users can enjoy more secure and reliable data exchange and control.

The MX-AOPC UA Server includes:

e Server Runtime Service: Starts as a service by default after installation.
¢ Configuration Console: An offline configuration tool for configuring server settings.

e Viewer: An OPC client that allows developers, testers, and integrators to easily view tag values and test
MX-AOPC UA Server and connections.

System Requirements

Hardware Requirements

CPU: Intel Pentium 4 or above

RAM: 512 MB (1024 MB recommended)
Communication Interface: Ethernet or serial

Software Requirements

Operating System: Microsoft Windows 7/8/10, Microsoft Windows Server 2003/2008/2012
Microsoft .NET Framework: v3.5 Service Pack 1

Editor (optional): Microsoft Office 2003 Excel or later

Specifications

OPC Server Specifications

OPC Unified Architecture: 1.02

OPC Data Access: 1.0a, 2.0, 2.05a, 3.0

Device Protocols: Moxa AOPC, Modbus/TCP (master), Modbus/RTU (master)

Products that Support AOPC Protocol

ioLogik: ioLogik 2500 Series, ioLogik E1200 Series, ioLogik E1500 Series, ioLogik E2200 Series, ioLogik
E4200, ioLogik W5300 Series, ioPAC 8500 Series, ioPAC 8600 Series

Note: Please check Moxa’s website for the most up-to-date list of supported products.
Fully Supported OPC UA Server Profiles

Standard UA Server Profile

Core Server Facet

e User Token - User Name Password Server Facet

e SecurityPolicy - None

Data Access Server Facet

UA-TCP UA-SC UA Binary

User Token - X509 Certificate Server Facet

SecurityPolicy - Basic128Rsal5

SecurityPolicy - None
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Getting Started

The following topics are covered in this chapter:

a

QQaaa

Q Q

Installing MX-AOPC UA Server
Configuring Active Tags

Opening the Configuration Console
Configuring Server Settings
Configuring Devices and Tags

» Adding a Modbus Device

> Creating Modbus Tags

Updating Configurations to the Server
Using the Viewer to Check Tag Values
Configuring OPC UA Settings



MX-AOPC UA Server Getting Started

Installing MX-AOPC UA Server

MX-AOPC UA Server can be downloaded from the Moxa website at www.moxa.com.

After downloading the file, unzip it and run setup.exe. The installation program will guide you through the
MX-AOPC UA Server installation process.

NOTE Microsoft .NET Framework v3.5 Service Pack 1 is required before installing MX-AOPC UA Server. After the .NET
Framework is installed, restart your computer and run setup.exe again to install MX-AOPC UA Server.

Configuring Active Tags

MX-AOPC UA Server will automatically receive active tags from Moxa’s remote devices through the Moxa AOPC
protocol once the tags are created. Refer to the device’s user’s manual to learn how to use the device’s
configuration utility to create active tags.

Opening the Configuration Console

Open MX-AOPC UA Server’s configuration console from the Windows Start menu: Start > All Programs >
MOXA - IO Server > MX-AOPC UA Suite > MX-AOPC UA Server.

Select main network adapter the first time you open the configuration console.

Select Main Metwork Adapter X

Main Metwork Adapter: |InteI{F'.]| Ethernet Connection (3) 1218-1M - |

Mote: The main network adapter needs to be enabled for starting runtime service,
This setting cannot be modified after this configuration.

[ QK ] | Cancel

The configuration console is an offline configuration tool for configuring Server Runtime settings. When the
configuration console is launched, it will automatically get the latest configurations from the Server Runtime.
If any active tag is received, the device will be listed in the Active Device List. To manually get the latest
configurations from the Server Runtime, click the Get Configuration from Server icon on the MX-AOPC UA
Server menu bar. To manually update the settings to the Server Runtime, click the Update Configuration to
Server icon on the menu bar.

2-2
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MX-AOPC UA Server Getting Started

B MX-AOPC UA Server =ne X

File Edit VYiew Tools Runtime Help

NASR ARG G[e 3]s

Group Mo Group Mame

i Active Device List
i/l Modbus Device Group List

Date Time Event

4 T

Service Status: Running Time: 16:02:49 b;vi.c;tount: 0 OPC Client Count: 0

NOTE The first time you use MX-AOPC UA Server, we recommend turning off, or adding rules to, the Windows Firewall
and then checking to see if MX-AOPC UA Server is able to receive active tags. If it can, turn the Windows
Firewall back on and check it again. If MX-AOPC UA Server does not receive any active tags after you turn on
the Windows Firewall, add aopcservice.exe in the Firewall Inbound Rules, and set it to Allow for Private, Public,
and Domain network profiles.

NOTE Be sure to update the settings to the Server Runtime after changing the configuration. Otherwise, the Server
Runtime will not reflect the configuration changes made using the configuration console.
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MX-AOPC UA Server

Getting Started

Configuring Server Settings

Before configuring devices and tags, configure the server settings described below under the Tools menu.

File Edit \iew

&

, o ot e

I_oo[s] Runtime Help

=14 Active Device
i bl E2242-01

o oo

Serial Port Settings

AQPC Settings
DCOM Configuration
OPC UA Settings

Wiewer

System Log
Change Password

Options

X

¢ Change Password

We strongly recommend changing the password the first time you use the Configuration Console. The
default password is *moxa”, which is needed for verification when updating configurations to the Server

Runtime or exporting the system log to a text file.

NOTE

When connecting an OPC UA client to MX-AOPC UA Server, use account name “admin” (the account name

cannot be changed) and whatever the password is. The password is the same as the system password, which
can be updated using Tools > Change Password.

e Serial Port Settings

Configure the PC’s Serial Port Settings if a serial device is connected to MX-AOPC UA Server.

Serial Port Settings

Port Baudrate Parity Data Bits Stop Bits Flow Control =
COM1 115200 Mone 8 1 Mone 4
COM2 115200 Mone 8 1 Mone

COM3 115200 Mone 8 1 Mone

COomM4 115200 Mone 3 1 MNong

COM5 115200 Mone 3 1 None

COMe 115200 Mone 8 i Mone

COoM7 115200 Mone 8 1 Mone

COMs 115200 Mone 8 1 Mone

COMS 115200 Mone 8 1 Mone i

Baud Rate: [ 115200 - ] Flow Control: [Ncne hd ]
Datafits: | ~| StopBits: |1 | Parity:  [None -

2-4
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e AOPC Settings
Configure AOPC Settings if a Moxa device updates Active Tags to MX-AOPC UA Server.

Default Metwork Interface: [I.ntel{ﬁ'_} §2577LM Gigabit Network Connection -
Active Tag Listen Port: 9900 Enabled
Command Timeout: 30 sec(s)
Heartbeat Tolerance: 30 sec(s)

| ok || cancel

Configuring Devices and Tags

Adding a Modbus Device

1. Click the Modbus Device Group List to select it and then click the New Device Group icon and type in
the name of the device group.

B! MX-AOPC UA Server

IEiIe Edit View Tools Runtime Help

i




MX-AOPC UA Server Getting Started

2. Click the New Device icon and then configure the device properties.

i - ' - e— L 3 - -
¥ MX-AOPC UA Server Pap— P R p— - .

ARG NS W

=1 Active Device List | Device Name Enabled Communication Port Protocol
B 254201 (00:90:epf5a: 26x)
i l E7_242—01[00:98:21::
=1 _Medbus Device Gy List

EE ) DeviceGroup1

Device Pm_

Device Name: Enable Data Collection

Communication Port: [Imﬂﬂl) Ethernet Connection (3 V]

Protocol; Modbus/TCP protocol
Device Settings Timeout Settings

Device ID: [1 Reconnect Delay:

IP Address: - : . Reconnect Cycles:

Port: 502 Cycle Delay:
— Polling Timeout:
Delay between Poling: 1000 (ms, 100 to 3600000; O disabled) Az
Poling Retries: 3
Date

2018/01/16
2018/01/16
2018/01/16
2018/01/16 |
2018/01/16 10:52:05 ~t20 254201 A1.07 s created.

3. Click the device group you just created to display a list of the devices in this group.

File Edit View Tools Runtime Help

NMEEndsKAng a3 .

(= Active Device List Device Name Enabled Communication Port Protocol Device ID

- [ 2542-01 (00:90:28:53: 21:68)
o ) E2242-01 (00:90:e8:21:b7:91) Devicel feg Intel(R) Ethernet Connect... Medbus/TCP protocol 1

= -{_l Modbus Device Group List
R

i [ Devicel




MX-AOPC UA Server

Getting Started

Creating Modbus Tags

1. Click the device name to select it and then click the New Tag Group icon and type in the name of the tag

group.

Ig MK—AOE HA S&ﬁ. -
Eile Edit View Tools Runtime Help

= =
Ll B .

|

&

SRR

{8 Active Device List

B 2542-01 (00:90:e8:5a;21:6¢)

Tag Group

The Firs!

Tag Group Mame:

ok | | Ccancel

2. Click the New Tag icon and then configure the tag properties.

Bl MX-AOPC UA Server

- - -

———

Eilel Ecﬁt View Icols Runtime Help

MrMeEsads

=8 Active Device List

B 2542-01 (00:90:e8:5a:21:68)
B E2242-01 (00:90:28: 21:b7:94
=/ Modbus Device Group List g

;' ).

ARBR G

Th_ First Tag Name

E-@ DeviceGroup1
= W Devicel

The Last Tag Mame

Function Code: [01: Read/Mirite Coils (0xxxx)

Access: Read/\Write

Tag Mame: Tagl

Description:

Start Address; 0

Coil Length: 1 {1 to 2000)

Data Type: [Bodean

Date

2018/01/16
2018/01/15
2018/01/16
2018/01/16
2018/01/16
2018/01/16
2018/01/16

Start Mumber: |0 {0 to 99)

Data Conversion

Tag Quantty:

2-7
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3. The tag will be listed in the tag group.

File Edit View Tools Runtime Help
ARG N

rMEEndss &

: Active Device List The First Tag Mame The Last Tag Name Tag Type Function Code Access
=1 Modbus Device Group List -
; 9 3
-] DeviceGroup1 §Tagl Poling 1 Read/Write
=- ) Devicel

. § '20Groupl

Updating Configurations to the Server

When you finish updating the configuration, click the Update Configuration to Server icon to update the
configuration to the Server Runtime. When the Verify Password window pops up, enter the correct password
and then click OK to activate the changes.

E! MX-AOPC UA Server —_——

File Edit View Tools Buntime Help

EEONIdSYKAREGE S

I -/ Active Device List Group No Group Name
- W 2542-01 (00:90:28:5a: 21:6e)

- [} E2242-01 (00:90:e8:21:b7:91) L et
=1 Modbus Device Group List
- DeviceGroupi
- | Devicel
L TagGroupl

——

Verify Password

e,

Please enter password:

Using the Viewer to Check Tag Values

After completely updating the Server Runtime settings, click the Viewer icon to open the viewer to check that
the tag value is correct.

oo TR, e

File Edit View Tools Runtime Help

NASYRALE G|83[K

Group No Group Name

- o
LEN B .
=~ Active Device List
B 2542-01 (00:90:e8:5a:21:6¢)
- ) E224201 (00:90:e8:21:b7:91)
(=Rt W Modbus Device Group List
[=)-E) DeviceGroupl
= | Device1
@ TagGroupl

1 DeviceGroup1
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The device tree in the left panel should be the same as the tree displayed by the configuration console. Click a
tag group name to display the group’s tag values in the right panel.

Eile Tools Help

i Active Device List Tag Mame Data Type Value Device timestamp {UTC) Time Zone UTC4T.Z. Quality Update Count
l 2542-01 (00:90:e8:5a:2]
B E2242-01 (00:90:e8:211L W Tagl Boalean i 05:20:34. 118 2018/01f16 UTC+3 13:20:34.118 2018/01/16 Good 405
h Modbus Device Group List
=t ) DeviceGroup1
&} Device1
LE TagGroupl
] i Sl K 1 3
Date Time Event =
2018/01f16 13:20:32 The tag 2542-01.AT-01 changes the value from 0.001 to 0.001 D
2018/01f16 13:20:27 The tag 2542-01.AI-03 changes the value from 0,026 to 0.026
2018/01f16 13:20:23 The tag 2542-01.AI-03 changes the value from 0.026 to 0.025
2018/01f16 13:20:23 The tag 2542-01.A1-01 changes the value from 0.000 to 0.001
2018/01f16 13:20:18 The tag 2542-01.A1-03 changes the value from 0.027 to 0.026
2018/01f16 13:20:18 The tag 2542-01,AI-01 changes the value from 0,001 to 0,000
2018/01f16 13:20:13 The tag 2542-01.AI-03 changes the value from 0.026 to 0.027
2018/01f16 13:20:13 The tag 2542-01.AI-01 changes the value from 0.001 to 0.001
2018/01f16 13:20:08 The tag 2542-01.A1-03 changes the value from 0.026 to 0.026
2018/01f16 13:20:04 The tag DeviceGroup1.Device 1. TagGroup1. Tag 1 changes the value from 0 to 1 v
A4t PR L R PR S N Mol EeinAnral A Ane
| [ | »
Ready Time: 13:20:35

Configuring OPC UA Settings

You should configure OPC UA settings before connecting an OPC UA client to MX-AOPC UA Server. To access
OPC UA Settings options, click Tools > OPC UA Settings. Instructions for each option are given below.

FEile Edit Wiew !Io-os Runtime Help
A — Serial Port Settings }g E% - ﬁ j
infl § | =N I E AL
Dl Active Devi AQPC Settings
ve Device
1§ E224201 DCOM Configuration Gy Memne:
=il OPC UA Settings 3 Server Endpoints Settings
E-E ) DeviceGr : :
=~ i Devig WViewer eeciRity Polioy
- S [ . Certificates Management

Change Password

Options

2-9
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Server Endpoints Settings
“Server Endpoints Settings” are a list of interfaces that UA clients can use to communicate with MX-AOPC

UA Server. MX-AOPC UA Server supports Universal Resource Locator (URL) binary type protocols.

To add a new interface to the list, select the appropriate network interface in the Network Interface
drop-down box and type the port number for the URL in the Port Number input box. Click Add to add this
new server endpoint to the list.

Server Endpoints Settings LX)

URL Status
opc.tops /192, 168,12, 112: 53192 MXAQPC fJUAServer Valid

Metwork Interface: [InteI{F‘.} 82577LM Gigabit Network Connection -

Port Mumber: 53192

opc.top: /192, 168,12, 112: 53192 MY AOPC JUAServer

Add H Delete H Apply ] [ Close ][ Help

Security Policy

The security policy is applied to connections between OPC UA clients and MX-AOPC UA Server. Security
options that can be selected are None, Basic128Rsal5: Sign, or Basic128Rsal15: Sign and Encrypt.
If Basic128Rsal5: Sign, Basic128Rsal5: Sign and Encrypt, or both of these options are selected, you will
need to configure Certificates Management settings (see below).

Security Policy Setting S|

Maone
["] Basic128R=a15 - Sign

|:| Basic128Rsa 15 - Sign and Encrypt

QK ] [ Cancel

NOTE

The default Account and Password for connecting an OPC UA client to the server are:

Account: admin
Password: moxa

The account name cannot be changed. To change the password, click Tools > Change Password.

2-10
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¢ Certificates Management

If the security policy is set to Basic128Rsal5: Sign, Basic128Rsal5: Sign and Encrypt, or both,
importing an OPC UA client’s CA (Certificate Authority) file into MX-AOPC UA Server, and exporting the
MX-AOPC UA Server’s CA file to OPC UA Clients are both required.

Click the Trust Clients tab, click Import, and select the client’s CA file to import it into MX-AOPC UA
Server.

Certificates Management e ]

Trust Clisnts | Instance Certificates

Client Name TEI
w4 T4 Local Disovery Server ncharleszle-chen o, con TAL ocal Dimover

Export... Femave Feject Viewr Certificate...

Close ] l Help

Click the Instance Certificates tab and click Export Server Certificate to export MX-AOPC UA Server’s
CA file to OPC UA Clients.

Certificates Management e ]
Tiust Clients | Instance Certificates
[ View Sepver Cerificate Cettificate M- AOPC A Server
iz from 201410728 09:42:23 AM to
’ o A e PO R e ] 2019/10/2 09:42:23 AN
[ Reissug Certificats |
Close ] [ Help

Click the Update Configuration to Server icon to enable any changes that have been made to the OPC UA
configuration.

NOTE After reissuing certificates or re-installing MX-AOPC UA Server, you will need to once again export the Server
Certificate to OPC UA clients.

2-11
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Configuration Console

The following topics are covered in this chapter:

O Main Screen Overview
O Menu Items
> File
Edit
View
Tools

Runtime

YV V VYV V V

Help



MX-AOPC UA Server Configuration Console

Main Screen Overview

MX-AOPC UA Server’s configuration console displays the mapped I/O device with the settings of every I/0 tag.
It also shows the Server Runtime status and number of OPC clients.

Eile Edit View Tools Runtime Help 2

_— —_— \,f - = = ~
NIEENIdS2K A0 998
4 Active Device List Tag Mame Data Type Access Rights Description
] @ : o
E1-13 Modbus Device Group List “S‘u‘ E2242-01.DI-00 Boolean Read-only DI
-] DeviceGroup1 “9' E2242-01.DI-01 Boolean Read-only DI
B Device1 -_:S“ E2242-01.01-02 Boolean Read-only DI
..l TagGroupl "'Su‘ E2242-01.DI-03 Boolean Read-only CI
5 E2242-01.D1-04 Boolean Read-only DI
Wy E2242-01.D1-05 Boolean Read-only Door Status
¥y E2242-01.01-06 Boolean Read-only DI
¥ E2242-01.D1-07 Boolean Read-only DI
4 Wy E2242-01.D1-08 Boolean 5 Read-only DI
Wy £2242-01.01-09 Boolean Read-only DI
¥ E2242-01.DI-10 Boolean Read-only DI
Wy E2242-01.DI-11 Boolean Read-only DI
& E2242-01.5ysConnect-00  Boolean Read-only System Connection
Date Time: Ewent -
2014/12f29 13:22:01 The value of the tag 'E2242-01.DI-11'is changed to O ‘E ‘
2014/12/25 13:22:01 The value of the tag 'E2242-01.DI-10' is changed to O | &
20141229 13:22:01 The value of the tag 'E2242-01.DI-09" is changed to 0
2014/12/29 13:22:01 The value of the tag 'E2242-01.DI-08' is changed to 0
2014/12/25 13:22:01 The value of the tag 'E2242-01.DI-07" is changed to O 6
2014/12{29 13:22:01 The value of the tag 'E2242-01.DI-06' is changed to O
20141229 13:22:01 The value of the tag 'E2242-01.DI-05" is changed to 0
20141229 13:22:01 The value of the tag 'E2242-01.DI-04 is changed to 0
2014/12f29 13:22:01 The value of the tag 'E2242-01.DI-03'is changed to 0 I
20141229 13:22:01 The value of the tag 'E2242-01.DI-02' is changed to 0
20141229 13:22:01 The value of the tag 'E2242-01.DI-01" is changed to 0
2014/12/29 13:22:01 The value of the tag 'E2242-01.DI-00' is changed to 0
20141229 13:22:01 The value of the tag 'DeviceGroup 1.Device 1. TagGroup 1. Tagl' is changed to 0
20141229 13:21:57 The value of the tag 'E2242-01.SysConnect-00' is changed to 1
J[]l14.f1 2479 13:21:57 The valie nf the tan 'F2242-01 .I'JT—11'| in rhianned tn 0 T
4 1 2
Service Status: Running 7 Time: 13:26:558 & Device Count:2 9 OPC Client Count: 1 10
No. |Zone Description
1 Software Title Displays the name of the software: MX-AOPC UA Server
2 Menu All configuration functions
3 Quick Launch Bar Frequently used icons
4 Device View All devices and tags
5 Detailed View Detailed settings of the devices and tags
6 Log View Server Runtime logs
7 Server Runtime Status Shows if the Server Runtime Service is Running or Stopped
8 Server Time Displays the server time (same as the PC’s time)
9 Numbers of Device Displays the number of devices listed in Device View
10 Numbers of OPC Client Displays the number of OPC clients connected to MX-AOPC UA Server
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Menu Items

All operations can be accessed from the following Menu items.

Use the File menu to manage project files, device tags, and server configuration.

e

B MX-AOQPC UA Server

File | Edit View Tools PRuntime Help
Mew Ctrl+M E
Open... Ctr+Q |9
Save Ctrl+5

Save As..,

Import... 2
Export... *

Get Configuration from Server

Update Configuration to Server

1 AOPC_Snd.acp

I I L

e New: Create a new project file.

e Open: Open an existing project file.

e Save: Save the current project.

e Save As: Save the current project file as another project with a different filename.
e Import:

» Ethernet Modbus Device (.csv): Import Ethernet Modbus devices into device groups from a csv file.

Item Format Length Note
DeviceGroupName 0to9, Ato Z, atoz Symbols 30 ".” is not allowed.
DeviceName 0to9, Ato Z, atoz, Symbols 30 ".” is not allowed.

Enable 0: disable; 1: enable -

CommunicationPort

Network adapter name

DeviceID 1 to 247 -
IPAddress XXX XXX XXX XXX -
Port 0 to 65535 -
ReconnectDelay(ms) 0 to 30000 -
ReconnectCycle Oto 10 -
CycleDelay(sec) 0 to 86400 -
PollingTimeout(ms) 0 to 30000 -
PollingRetries 0to 10 -

DelayBetweenPolls(ms)

100 to 3600000; O disabled
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» Serial Modbus Device (.csv): Import Serial Modbus devices into device groups from a csv file.

Item Format Length Note
DeviceGroupName 0to9, Ato Z, atoz Symbols 30 “.” is not allowed.
DeviceName 0to9, Ato Z, atoz Symbols 30 “.” is not allowed.

Enable

0: disable; 1: enable

CommunicationPort

Serial port name

DevicelD

1 to 247

ResponseTimeout(ms)

0 to 30000

» Device Tags (.csv): Import device tags into a Modbus device from a csv file.

1 to 125 when function code is 3 or 4.

Item Format Length Note
GroupName 0to9, Ato Z, atoz Symbols 30 ".” is not allowed.
TagName 0to9, Ato Z, Symbols 30 ".” is not allowed.
FunctionCode 1to4 - 1: Read/Write Coils
2: Read Discrete Inputs
3: Read/Write Holding
Registers
4: Read Input Registers
Address 0 to 65535 -
DataType Boolean - e Use Boolean with
Unsigned short integer FunctionCode 1 or 2.
Unsigned integer e Use other DataTypes with
Float FunctionCode 3 or 4.
Description 0to9, Ato Z, atoz Symbols 25
TagQuantity 1 to 2000 when function code is 1 or 2. | TagQuantity

DataConversion

None

“LoByte & HiByte” (if Unsigned Short
Integer is defined)

“HiByte & LoByte” (if Unsigned Short
Integer is defined)

“LoWord & HiWord” (if Unsigned
Integer or Float is defined)

“HiWord & LoWord” (if Unsigned
Integer or Float is defined)

StartNumber

0 to 99

e Export:

» Ethernet Modbus Device (.csv): Export Ethernet Modbus devices from device groups to a csv file.

» Serial Modbus Device (.csv): Export Serial Modbus devices from device groups to a csv file.

» Device Tags (.csv): Export device tags from a Modbus device to a csv file.

e Get Configuration from Server: Get the latest configuration from the Server Runtime.

e Update Configuration to Server: Update the configuration to the Server Runtime from the Configuration

Console.

¢ Previous saved files: Quickly open previously saved project files.

e Exit: Close the Configuration Console.

NOTE Active Tags cannot be imported into an Active Device folder in the Configuration Console from a csv file, or vice
versa. Active Tags are automatically created by a Moxa active tag device. Refer to the Specifications section
for the Products that Support AOPC Protocol, and refer to the device’s user’s manual to see how to create
active tags using the device’s configuration utility.

NOTE Execute the Export function to get a csv template.
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Edit

Use the Edit menu to edit settings of devices and tags.

Eile[Eal'i View Tools Runtime Help

—]

Cut

Copy
Faste

Delete
Select All

Mew Device Group
Mew Device

Mew Tag Group
Mew Tag

Properties...

Cirl+3
Ctrl+C
Ctrl+V

Del

Ctrl+A

b &

Tag Mame

ki Tagl

e Cut: Cut a tag group or selected tags.

e Copy: Copy a tag group or selected tags.

e Paste: Paste a cut or copied tag group into a device, or paste cut or copied tags into a tag group.

o Delete: Delete the selected device, a selected tag group, or selected tags.

e Select All: Select all tags in a tag group.

¢ New Device Group: Create a new device group.

e New Device: Create a new Modbus device.

e New Tag Group: Create a new tag group.

e New Tag: Create a new tag.

* Properties: Modify the settings of an existing device group, device, tag group, or tag.

NOTE The properties of an active device or active tag cannot be modified from the configuration console. Refer to the
device’s user’s manual to see how to use the device’s configuration utility to change active device or active tag
settings.

View

Use the View menu to change the display settings of the Device View panel.

File Edit [Eiew] Tools Runtime Help

N

o Expand All Devices: Expand all devices in the Device View panel.

| 1% Active DEVEETIEE

Expand All Devices Ctrl+H
Collapse All Devices Ctrl+H
I'T Graun Mo
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o Collapse All Devices: Collapse all devices in the Device View panel.

Tools

Use the Tools menu to configure serial ports, OPC settings, system log, password, console environment
settings, or to launch Viewer.

- -

File Edit View !Ioosl Runtime Help

— S -
5 TF
E|l Active Device
L L. E2242-01

- i W Modbus Devit

Serial Port Settings

AOPC Settings
DCOM Configuration
OPC UA Settings

Viewer

System Log
Change Password

Options

B
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e Serial Port Settings

Serial Port Settings

Port Baudrate Parity Data Bits Stop Bits Flow Control *
COM1 115200 Mone 8 1 None
COM2 115200 Mone 8 1 None
COM3 115200 Mone 8 1 MNone
COM4 115200 Mone 8 1 MNone
COM3 115200 Mone 8 1 Mone
COM& 115200 Mone 8 1 MNone
COM7 115200 Mone 8 1 None
COMs 115200 Mone 8 1 MNone
COomM3 115200 Mone 3 1 MNone s
Baud Rate: [1]_5200 vl Flow Contral: [None
DataBits: |8 -] Stop Bits: |1 | Parity:  [None -
> Baud Rate: 300 to 921600 bps; default: 115200 bps
» Flow Control: None, RTS/CTS, or XON/XOFF; default: None
> DataBits: 5, 6, 7, or 8; default: 8
» Stop Bits: 1 or 2; default: 1
» Parity: Even, Odd, or None; default: None

e AOPC Settings

AOPC Settings
Default Metwork Interface: [InteI{R}l B2577LM Gigabit Network Connection -
Active Tag Listen Port: 9300 Enabled
Command Timeout: 30 sec(s)
Heartbeat Tolerance: 30 gec(s)
[ oK ] [ Cancel

> Default Network Interface: Select a network interface that remote devices can use to connect to

MX-AOPC UA Server.

> Active Tag Listen Port: The preferred TCP socket port for receiving active tags from remote devices

(default: 9900).

» Command Timeout: The socket timeout interval (Port: 9500 and 9900) for controlling output

channels on remote devices: 0 to 60; default: 30 sec.

> Heartbeat Tolerance: An additional timeout interval to wait for a heartbeat signal from remote

devices: 0 to 60; default: 30 sec.

e DCOM Configuration: Configure DCOM settings for your security policy. Refer to Appendix A for details.
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e OPC UA Settings

= L
T o

Eile Edit View I Tools | Runtime Help
P — Serial Port Settings % E% ﬁ @ ; u
LHN B . =
i A ADQPC Settings
ve Device
=R} Modbus Devic DCOM Configuration e Heme
G- DeviceGr OPC UA Settings » Server Endpoints Settings
s Security Policy
il . Certificates Management
Change Password
Options

» Server Endpoints Settings:

“Server Endpoints Settings” are a list of interfaces that UA clients can use to communicate with
MX-AOPC UA Server. MX-AOPC UA Server supports Universal Resource Locator (URL) binary type
protocols.

To add a new interface to the list, select the appropriate network interface in the Network Interface
drop-down box and type the port number for the URL in the Port Number (default: 53192) input box.
Click Add to add this new server endpoint to the list.

e ircponts e I =

URL Status
opc. top:ff192. 168, 12, 112: 53192 MXACPC UAServer Valid

Metwork Interface: [Intel{FtJ 82577LM Gigabit Metwork Connection -

Port Mumber: 53192

opc. top: /192,168, 12, 112: 53192 MYADPC UAServer

Add || Delete || apply | | close || Hep
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> Security Policy
The security policy is applied to connections between OPC UA clients and MX-AOPC UA Server. Security
options that can be selected are None, Basic128Rsal5: Sign, or Basic128Rsal5: Sign and
Encrypt. If Basic128Rsal5: Sign, Basic128Rsal5: Sign and Encrypt, or both of these options are
selected, you will need to configure Certificates Management settings (see below).

Security Policy Setting X

MNone
[| Basic128Rsa15 - Sign

|:| Basic128Rsa15 - Sign and Encrypt

Ok ] [ Cancel

NOTE The default Account and Password for connecting an OPC UA client to the server are:
Account: admin
Password: moxa
The account nhame cannot be changed. To change the password, click Tools > Change Password.

» Certificates Management

If the security policy is set to Basic128Rsal15: Sign, Basic128Rsal5: Sign and Encrypt, or both,
importing an OPC UA client’s CA (Certificate Authority) file into MX-AOPC UA Server, and exporting the
MX-AOPC UA Server'’s CA file to OPC UA Clients are both required.

Click the Trust Clients tab, click Import, and select the client’s CA file to import it into MX-AOPC UA
Server.

Certificates Management e ]

Tzt Clisnts | Instance Certificates

Client Warme TRI
o T4 Local Discovery Server urncharlessk-chen moxa com: T AL ocalDiscover

Export... Femaove FEeject View Cerhificate. ..

Close ] [ Help
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Click the Instance Certificates tab and click Export Server Certificate to export MX-AOPC UA

Server’s CA file to OPC UA Clients.

Tiust Clients | Instance Certificates |
[ Vigw Server Certificate Cettificate MEX-AOPC UA Server
is from 2014/10/28 09:42:33 AM to
[ Export Server Certifisate... ) 201971072 09:42:23 AN
( Reissue Certificate |
Close ] [ Help

Click the Update Configuration to Server icon to enable any changes that have been made to the

OPC UA configuration.

NOTE After reissuing certificates or re-installing MX-AOPC UA Server, you will need to once again export the Server

Certificate to OPC UA clients.

e Viewer: Open the viewer to check that the tag value is correct.

e System Log

File Edit \iew !Ioos Runtime Help

PIETmvesss . .

s mmm e Serial Port Settings
AQPC Settings
=i Active Device
Bl DCOM Configuration
- ) DeviceGr OPC UA Settings
Viewer
System Log

Change Password

Options

XNERA»

Group Mame
5 DeviceGroupl
3 Cawve to Text File

Reset System Log
Systemn Log Settings
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» Save to Text File: Save MX-AOPC UA Server’s system log to a text file. You will be required to enter
a password (default password: moxa).

Verity Password S

Please enter password:

K ] [ Cancel

> Reset System Log: Reset MX-AOPC UA Server’s system log. You will be required to enter a password
(default password: moxa).

ActiveOPC |

— Verify Password |t

| Do you want to reset system log?
— Please enter password:

i l ’ s [ Ok ” Cancel

» System Log Settings: Defines the maximum number of records that can be saved in the MX-AOPC UA
Server’s system log: 1 to 30000; default: 30000.

System Log Settings

Event Records: 30000 (1~30000)

QK ] [ Cancel

¢ Change Password: Change the MX-AOPC UA Server’s system password. The password is required when
updating configurations to System Runtime, saving system logs to a text file, or resetting system log.
Length: 4 to 128; acceptable characters: Ato Z, ato z, 0 to 9, Symbols; default: moxa.

Change Password S

Old Password;

Mew Password:

Confirm Password:

Ok ] [ Cancel
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e Options: Configure environment settings for the server’s configuration console.

Startup

@ Get configuration from Server

(") Open previous configuration file

Configuration File
Automatically save configuration every 10 min(z)
Automatically save configuration before updating to server

Automatically save configuration before exiting this console

| ok || cancl

NOTE If Automatically save configuration every xx min(s) is enabled, the configuration file will be automatically
saved only when a file name is defined. Be sure to save your configuration file after creating a new project file.

Runtime

Use the Runtime menu to Start, Stop, or Reinitialize Server Runtime Service.

[ e |

Eile Edit View Tools iﬂuntime Help
S e Ei Start Server Runtime Service
LN B

Stop Server Runtime Service

-1l Active Device List Reinitialize Server Runtime Service I

I Ell Modbus Device Group (S :
2 | I i Devicel

-Ef DeviceGroupl

Help

Use the Help menu to launch the server’s help documentation, to check the server’s license status, to add a
license file, or check server version.

Eile Edit View Tools Runtime !ﬂep

i __‘Fi ﬁ ngl Server Help

Licensing *
- Active Device List ey s
-
[-@ DeviceGroupl | I 2

e Server Help: Launch MX-AOPC UA Server’s help documentation.
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e Licensing

& a0 ua sen

File Edit View Tools Runtime EHer

- i — E—. | . Server Help i o ‘
e s Licensing ] License Info
-3 Active Device List Aboit... Add License File r

=1 Y Modbus Device Group List
-0 DeviceGroupl

Deactivate License

> License Info: Displays the server’s User Code, License Status, and the Time Remaining on the license.
Refer to Chapter 6: License Registration and Activation to learn how to activate the license.

User Code il u

User Code: 1513EB128766
License Status: Trial Version

Time Remaining: 11 days

> Add License File: Import a license file after completing the license registration process. Refer to
Chapter 6: License Registration and Activation to learn how to activate the license.

> Deactivate License: Deactivate the current paid license version and load factory default settings.
Note that when you deactivate the license, your license file and runtime configurations will be deleted.
Please backup your runtime configurations before executing a license deactivation procedure.

e About: Displays MX-AOPC UA Server’s version number and build humber.

Moxa MX-AOPC LIA Server 1.0 build 14122910

ﬁ Copyright (C) 2014 Moxa Inc.

About
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Management

The following topics are covered in this chapter:

O Device Group

» Adding a Device Group

» Editing a Device Group

> Deleting a Device Group
O Active Devices

> Deleting an Active Device from the Active Device Group List
O Modbus Devices

» Adding a Modbus Device to a Device Group

Importing a List of Modbus Devices into Device Groups

>

> Editing a Modbus Device
» Deleting a Modbus Device
>

Moving a Modbus Device to a Different Device Group
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Device Group

In this section we explain how to use the configuration console to add, edit, and delete device groups.

MX-AOPC UA Server’s design logic is user-application oriented. As seen below, device groups can be created
based on application, such as SiteA or SiteB.

gl MX-AOPC UA Server

Eile Edit View Tools Runtime Help

TEENdsSs8 A0 99 8 |

% Active Device List Group Mo Group Name
B E2242-01 (00:90:e8: 16:e7: 15)
o8

N E
i =~ [} ioLogk E2242
& Pump
-0 SiteB
- ) ioLogik E2242

1 SiteA
2 SiteB

Date Time Event

20141229 13:22:01 The value of the tag 'E2242-01.DI-11" is changed to 0
2014/12/25 13:22:01 The value of the tag 'E2242-01.DI-10' is changed to 0
20141229 13:22:01 The value of the tag 'E2242-01.DI-09" is changed to 0
20141229 13:22:01 The value of the tag 'E2242-01.DI-08" is changed to 0
2014/12/29 13:22:01 The value of the tag 'E2242-01.DI-07" is changed to 0
2014/12{29 13:22:01 The value of the tag 'E2242-01.DI-06' is changed to 0
20141229 13:22:01 The value of the tag 'E2242-01.DI-05 is changed to 0
2014/12/29 13:22:01 The value of the tag 'E2242-01.DI-04' is changed to 0
2014/12f29 13:22:01 The value of the tag 'E2242-01,DI-03'is changed to 0
20141229 13:22:01 The value of the tag 'E2242-01.DI-02 is changed to 0
20141229 13:22:01 The value of the tag 'E2242-01.DI-01' is changed to 0
2014/12{29 13:22:01 The value of the tag 'E2242-01.DI-00' is changed to 0
20141229 13:22:01 The value of the tag 'DeviceGroup 1.Device 1. TagGroup1.Tagl' is changed to 0

20|141’12.’29 13:21:57 The value of the tao 'E2242-01.SvsConnect-00' is chanaed to 1
] i

Service Status: Running Time: 13:55:46 Device Count: 3 OPC Client Count: 1

Adding a Device Group

1. Right click Modbus Device Group List and then click New Device Group in the popup menu, or click
Modbus Device Group List to select it, and then click the New Device Group icon on the Quick Launch
toolbar.

File Edit View Tools Runtime Help

T — [ . g “’
Elli Active Device List Group Mo

: s B E2242-01 (D0:50:e8:16:27: 15)
Lt W Modbus Device Group List

Mew Device Group
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2. Type in the name of the device group (max. length = 30 characters;

Device Group Prc-pe__

w o

.”is not allowed), and then click OK.

Device Group Mame:

| ok || canel

3. The new device group will be added to the Modbus Device Group List.

Eile Edit \iew Tools Runtime Help

iy §

adsD

|T;|----:]i Active Device List

E|]i Modbus Device Group List

------ i) DeviceGroup1

Editing a Device Group

o B E2242-01 (00:90:e8: 16:e7:15)

Dewvir

Right click the device group you would like to edit and then click Properties in the popup menu, or click the
device group to select it and then click the Properties icon on the Quick Launch toolbar to open the properties

window.

File Edit WView Tools Runtime Help

——

nf B

s

o] %

=i Active Device List
i =) E2242-01 (00:90:28: 16:€7: 15)
=+ Modbus Device Group List

Device Mame

Mew Device

Delete

Properties..

Ctrl+D
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Deleting a Device Group

Right click the device group you would like to delete and then click Delete in the popup menu, or click the
device group to select it and then click the Delete icon from the Quick Launch toolbar.

i MX-AOPC UA Server

Eile Edit \iew Tools Runtime Help

TEAENASDK AR RG]

& li Active Device List Device Name Enabled
P e B E2242-01 (00:90:e8:16:27: 15)
=+ Modbus Device Group List

FEE) i‘i

Mew Device

Delete Ctrl+D

Properties...

L |

Active Devices

In this section we explain how to use the configuration console to delete active devices.

MX-AOPC UA Server will automatically receive the registration from a Moxa active device located at a remote
site. Refer to the Moxa I/O device’s user’s manual to learn how to use the device’s configuration utility to create
active tags.

Deleting an Active Device from the Active Device Group List

Right click the active device you would like to delete and then click Delete in the popup menu, or click the
active device to select it and then click the Delete icon from the Quick Launch toolbar.

File Edit ¥View Tools Runtime Help

ITEENAS R eE]s

EI I: Active Device List Tag Name Data Type
P e ] EZ2242-01 (00:90:e8: 16:27:15 =
I : . 3 742-01.0I-00 Boolean
= I: Modbus Device Group Lis Delete
] DeviceGroup1 P42-01.01-01 Boolean
% E2242-01.D1-02 Boolean
B £774701 RTong Brnlazn

NOTE After an active-device name is changed through the web console or configuration utility, delete the active
device on the MX-AOPC UA Server and execute “Update Configuration to Server.” The change will take effect
the next time the device creates active tags to the MX-AOPC UA Server.
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Modbus Devices

In this section we explain how to use the configuration console to add, edit, delete, and move Modbus devices.

Adding a Modbus Device to a Device Group

Right click the device group you would like to add a new Modbus device to and then click New Device in the
popup menu. You may instead click the device group to select it and then click the New Device icon on the
Quick Launch toolbar.

, R

File Edit View Tools Runtime Help
i S E‘J‘ a;
LEe B . L2

& !1 Active Device List TP —
to ) E2242-01 (00:90:e8: 16:27: 15)

Mew Device

Delete Ctrl+D

Properties...

Ethernet Communication Port

If an Ethernet communication port is selected, the Device Property configuration window will appear as
shown below:

voreropery

Device Name: | SIS Enable Data Collection

Communication Port: ’Intel{R} Ethernet Connection (= Y]

Protocol: Modbus/TCP protocol

Device Settings Timeout Settings
Device ID: [1 vl Reconnect Delay: 3000 ms
IP Address: (R R Reconnect Cydes: 3
Port: 502 Cyde Delay: 3 sec(s)
Palling Timegut; 3000 ms

| Delay between Polling: 1000 (ms, 100 to 3600000; 0 disabled)
Foling Retries: 3

[ oK J[ Cancel

¢ Device Name: Name of the Modbus device (max. length = 30; “.” is not allowed).
o Enable Data Collection: Enable or disable data collection for this Modbus device.
e Communication Port: Select the communication interface of this Modbus device.

¢ Device ID: The device ID of this Modbus device (options: 1 to 247).
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IP Address: The IP Address of this Modbus device.
Port: The TCP port of this Modbus device (options: 0 to 65535).

Delay between Polling: The delay time after the server polls Modbus register(s) of this device (options:
ms, 100 to 3600000; 0 disabled).

Reconnect Delay: The delay time after the server tries to reconnect this Modbus device (options: 0 to
30000; default: 3000).

Reconnect Cycles: The maximum number of reconnect cycles (options: 0 to 10; default: 3).

Cycle Delay: The delay time after reaching the maximum number of reconnect cycles (options: 0 to 86400;
default: 3).

Polling Timeout: The timeout value when the server polls data from this Modbus device (options: 0 to
30000; default: 3000).

Polling Retries: The maximum number of retries after a polling timeout occurs (options: 0 to 10; default:

3).
Polling Retry | Reconnect Cycle i
- When no response, waiting Reached : When failure, waiting untl E Reached
Poll 3 s S = = - 3
¢ PONN9 == ntil Polling Timeout Polling Retries — 1 = Reconnect —> peconnect Delay ' Reconnect Cycles
Al ‘ i Waiting until
! ' Cycle Delay

i Retry b Retry ‘

Serial Communication Port

If a serial communication port is selected, the Device Property configuration window will appear as shown

below:
Device Property
Device Mame: Devicel [¥] Enable Data Collection
Communication Port: [CDMI =
Protocol: Modbus/RTU protocol
Device Settings Timeout Settings
Uit I0: | 1 v] Response Timeout: 3000 ms
Poling Delay: 10 ms

QK ] | Cancel

The following configuration items only appear when a serial communication port is selected.

Response Timeout: The timeout value when the server polls the data of this Modbus device (options: 0 to
30000; default: 3000).

Polling Delay: The delay time after a polling timeout occurs (0 to 60000; default: 10).
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The newly created device group will now be shown as belonging to this group.

e S T =

File Edit View Tools Runtime Help

S aamm s — i}' - \ré - = - -
Bl " A;ﬁve Device List Device Name Enabled Communication Port Protocol Un|
- | E2242-01 (00:90:e8: 16:7:15) i e
= Modbus Device Group List DEVfcel Yes Intel(R) 82577LM Gigabit ... Modbus/TCP protocol i
: DeviceGroup1 Device2 Yes coM1 Modbus/RTU protocol i
B Devicel
il B Device2 I

Importing a List of Modbus Devices into Device Groups

Right click the Modbus Device Group List and then click Ethernet Modbus Device (.csv) or Serial Modbus
Device (.csv) in the popup menu to import a list of Modbus devices into device groups. Select a csv file on your
PC to import the devices listed in the csv file into the Device Groups. Refer to Chapter 3: Configuration
Console > Menu Items - File for detailed csv file formats.

consete >
& v e S

File Edit View Tools Runtime Help

e . mm | - —_— . : - =
3 : | = = 3
TEENASDRAREGHII L
Active Device List Group No Group Name
B 2542-01(00:90:e8:5a: 21:6e) 3 e ™
1 E2242-01 (00:90:€8:21:b7:91) Slis il
5t
""" MNew Device Group i
Import... 3 Ethernet Modbus Device (.csv)
|| Export... 3 Serial Modbus Device (.csv)

Editing a Modbus Device

Right click the Modbus device you would like to edit and then click Properties... in the popup menu, or click the
Modbus device to select it and then click the Properties icon in the Quick Launch toolbar to open the properties
configuration window.

File Edit Wiew Tools Runtime Help

nmwads R4 e

SEe Eoal K R R =

=/ Active Device List Taq Group

o )l E2242-01 (00:90:28:16:27:15)

=/ Modbus Device Group List

=-E) DeviceGroupl
'3

MNew Tag Group
Move to Device Group 2
Paste Ctrl+W
Delete Ctrl+D

Import Device Tags (.csv)...
Export Device Tags (.csv)...

TET

Properties...

NOTE You are not allowed to cut, copy, or paste a Modbus device.
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Deleting a Modbus Device

Right click the Modbus device and then click Delete in the popup menu, or click the Modbus device to select it
and then click the Delete icon in the Quick Launch toolbar.

File Edit Wiew Tools Runtime Help
—— — - =
[ =

FTEFENIdsH& A2 l;j@ﬂ
-1 Active Device List Tag Group Tag Name -
¢ - ) E2242-01(00:50:e8: 16:27:15)
I (=~ Modbus Device Group List
=& DeviceGroupl

e

B Device?

Mew Tag Group

Maowe to Device Group 3

Paste Ctrl+V
Delete Ctrl+D

Import Device Tags (.csv)...
Export Device Tags (.csv)...

1

Properties...

Moving a Modbus Device to a Different Device Group

1. Right click the Modbus device and then click the target device group in the popup menu.

Eile Edit View Tools Runtime Help

TEEAASIRABES
FeEFadsD ERAE B
@""-l Active Device List Tag Group Tag Name Tat
- ) E2242-01 (00:90:e8: 15:e7:15)
I E|l Modbus Device Group List
=B DeviceGroupl
B Devicel
)
""" Mew Tag Group i
Maowe to Device Group [ DeviceGroupl
Paste Cirl+V DeviscCeoup?
Delete Ctrl+D
Import Device Tags (.csv)...
1
Export Device Tags (.csv)...
Properties...
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2. The Modbus device will be moved to the target device group.

File Edit View Tools Runtime Help
e s e Ei [. —_—
1 I |G e &
El Active Device List
te ) E2242-01 (D0:90:28: 16:27: 15)
E|l Modbus Device Group List

E|i] DeviceGroupl

L ) Devicel
=~ DeviceGroup2

-
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Tag Management

The following topics are covered in this chapter:

O Tag Groups
» Adding a Tag Group to a Device
Editing a Tag Group
Cutting a Tag Group
Copying a Tag Group

YV V V V

Pasting a Tag Group
> Deleting a Tag Group
O Modbus Tags
» Adding a Modbus Tag to a Tag Group
> Importing a List of Modbus Tags into a Modbus Device
» Editing a Modbus Tag
» Deleting a Modbus Tag
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Tag Groups

In this section we explain how to use the configuration console to add, edit, cut, copy, paste, and delete tag
groups.

Adding a Tag Group to a Device

1. Rightclick the device that the tag group will be added to and then click New Tag Group in the popup menu,
or click the device to select it and then click the New Tag Group icon on the Quick Launch toolbar.

File Edit View Tools Runtime Help

P Ei |. %, >< H
e E.gl N -
Ell Active Device List Taq Group
| A 1 E2242-01 (00:90:28: 16:7: 15)
Ell Modbus Device Group List
=-E) DeviceGroupl

-
Mew Tag Group
Move ta Device Group »
Paste Ctrl+V
Delete Ctrl+D

Import Device Tags (csv)...
Export Device Tags (csv)...

Properties...

Date

2. Type in the name of the tag group (max. length = 30 characters; “.” is not allowed) and then click OK.

Tag Group PropertyA

Tag Group Mame:

Lok J[ cancd |

3. The new tag group will be added to the device.

File Edit View Tools Runtime Help
gy —

FMEFOdsSS
El} Active Device List Tag!
¢ b ) E2242-01 (00:90:e8: 16:27:15)
=% Modbus Device Group List
=@ DeviceGroupl
B B Device1

|| g T20Goun 1
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Editing a Tag Group

Right click the tag group and then click Properties in the popup menu, or click the tag group to select it and
then click the Properties icon on the Quick Launch toolbar.

File Edit Miew Tools Runtime Help

el B sl ¥ \"'
' 2 '
EHE NS A
B]ﬁ Active Device List Tag Name
b B E2242-01 (00:90:28:16:27:15)
B!ﬁ Modbus Device Group List
E-EJ DeviceGroupl

= ) Devicel
= IZEEE
Mew Tag
Cut Ctrl+X
Copy Ctrl+C
Delete Del
Properties

Cutting a Tag Group

Right click the tag group and click Cut in the popup menu, or click the tag group to select it and then click the
Cut icon on the Quick Launch toolbar.

File Edit \iew Tools Runtime Help

ey — v \
| W b =
oy R ﬂul&@&lﬂ'L
B]ﬁ Active Device List Tag Name
L ke B E2242-01 (00:90:e8: 16:27: 15)
I B]ﬁ Modbus Device Group List
Bi] DeviceGroupl
= ] Devicel
= [
Mew Tag
Cut Chrl+%
Copy Ctrl+C
Delets Del
Praperties
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Copying a Tag Group

Right click the tag group and then click Copy in the popup menu, or click the tag group to select it and then
click the Copy icon on the Quick Launch toolbar.

File Edit Wiew Tools Runtime Help
}g n

Ty — - — >
159 &
F'EmENds
Bl Active Device List Tag Mame Tag Tyr
. 1 E2242-01 (00:90:28: 16:27:15)
Bl Modbus Device Group List
=& DeviceGroupl

= ) Devicel
B TagGroup |
Mew Tag
Cut Ctrl+X
Copy Ctrl+C
Delete Del
Properties
T

Pasting a Tag Group

Right click the Tag Group and then click Paste in the popup menu, or click the tag group to select it and then
click the Paste icon on the Quick Launch toolbar.

File Edit View Tools Runtime Help

T — [ — - % =

Ll B . Ei @-.. & B “" ) @
Bl Active Device List Taq Group Taq Name

o b ) E2242-01 (00:90:e8: 16:27: 15)

B]i Modbus Device Group List
E-E DeviceGroupl

=~ W Devicel

. - TagGroupl
Mew Tag Group
Move to Device Group »
Paste Ctrl+V
Delete Ctrl+D

Import Device Tags (csv)... i

Export Device Tags (.csv)...

Properties...
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Deleting a Tag Group

Right click the tag group and then click Delete in the popup menu, or click the tag group to select it and
then click the Delete icon on the Quick Launch toolbar.

File Edit \iew Tools Runtime Help

—— — S = - v __,
NEEODASR A2 el)e
B’i Active Device List Tag Name Tag Type

: B E2242-01 (00:90:28:16:27:15)

=14 Modbus Device Group List
E-E DeviceGroupl

= ] Devicel
4 TanGroup|

Mew Tag

Cut Crl+X
Copy Ctrl+C
Delete Del
Properties

T

TN

Modbus Tags

In this section we explain how to use the configuration console to add, edit, delete, and move a Modbus tag.

Adding a Modbus Tag to a Tag Group

1. Right click the tag group that the Modbus tag will be added to and then click New Tag in the popup menu,
or click the tag group to select it and then click the New Tag icon on the Quick Launch toolbar.

E@ MX-A0PC UA Server
Eile Edit View Tools Runtime Help

o S o S 2 [ \ : "'%I
L@ﬂﬁﬂM@WM%
(= B Active Device List
o b 2542-01 (00:90:e8:55: 21:6e)
: e B E2242-01 (00:90:e8:21:b7:91)
=/ Modbus Device Group List

=-§) DeviceGroupl

= [ Devicel

o roun:

Mew Tag

Cut Ctrl+X
Copy Ctri+C
Delete Del
Properties
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Tag Management

2. Edit the items in the Tag Property window as needed.

Tag Property
Function Code: II:Il: Read Mrite Coils (Do) -
Access: Read/MWirite
Tag Mame: Tagl
Description:
Start Address: 0

Coil Length: 1 {1 to 2000)
Data Type: |Boolean v] |
Start Number: |0 (0 to 99) |
Data Conversion: | Mone
Tag Quantity: 1
Ok ] I Cancel

> Function Code: Select the function code for this Modbus tag (options: 01: Read/Write Coils; 02: Read
Discrete Inputs; 03: Read/Write Holding Registers; 04: Read Input Registers).

» Address: Show Read/Write or Read-only attribute of this tag(s).

» Tag Name: The name of the Modbus tag (max. length = 30; “.” is not allowed).

> Description: Description of this Modbus tag (max. length = 25).

» Start Address: Define the start address of this Modbus tag (0 to 65535).

> Coil Length / Register Length: Define the length of the coil (1 to 2000) or the register (1 to 125).

> Data Type: Selecting the data type of this Modbus tag (options: Boolean; Unsigned short integer;
Unsigned integer; Float).

» Start Number: Define the start number of the continuous coils or registers. The continuous coils or
registers will be divided into different tags with unique name based on this number definition.

> Data Conversion: Define the sequence of the High/Low Bytes or Words for the register(s).

» Tag Quantity: Show the quantity of the tag(s).

3. Click the tag group to verify that the Modbus tag was added to this group.

E! MX-AOPC UA Server

File Edit View Tools Runtime Help

NAISRKACLGII &

me IR

-1l Active Device List
i b P 2542-01(00:90:e8:5a:21:6e)
“ ) E2242-01 (00:90:e8:21:b7:91)
)-8 Modbus Device Group List
-0 DeviceGroupl
B Devicel
i TagGroupl

The FirstTagName  The LastTagName TagType Function Code Access

W Tagl
% Tag2_0000

Poliing 2 Read-only

Tag2_0002 polling 1

5-6

Read/Write 0007 3

StartAddress TagQty DataType StartMumber DataConversion Description

0000 1 Boolean 0 None

Boolean 0 None
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Importing a List of Modbus Tags into a Modbus Device

To import a list of Modbus tags into a Modbus device, right click the Modbus device and then click Import
Device Tags (.csv) in the popup menu. Select a csv file on your PC to import the tags listed in the csv file into

the Modbus device. Refer to Chapter 3: Configuration Console - Menu Items - File for detailed csv file
formats.

File Edit Wiew Tools Runtime Help
e S A - — td -
NMEENIdSHR AR

EI]i Active Device List Tag Group
| A 1 E2242-01 (00:90:e8: 16:e7: 15)
El]i Modbus Device Group List
Bi] DeviceGroup1
B JDevice1
Mew Tag Group
Move to Device Group b
Paste Ctrl+V
Delete Ctrl+D
Import Device Tags (.csv)...
Export Device Tags (.csv)... -
—

Properties... -

Date Ti

Editing a Modbus Tag

Click the Modbus tag to select it and then click the Properties icon on the Quick Launch toolbar.

File Edit View Tools Runtime Help

TR ER LIEE NN

TmB

f i Active Detace [ist The First Tag Name The Last Tag Mame Tag Type Function Code Access
B ooy | [ O S S > TR
B E2242-01(00:90:e8:21:b7:91) 2 il ead-only

Modbug Device Group List
i DeviceGroup1l

- 1 Devicel
LeEm TagGroupl

Deleting a Modbus Tag

Click the Modbus tag to select it and then click the Delete icon on the Quick Launch toolbar.

& oo S < )
File Edit View Tools Runtime Help |
- — — ¢ (4 - 1l
iASS® Aepjujer s
NMEFDdse® A2k .
||| -1 Active Device List The First Tag Name The Last Tag Mame Tag Type Function Code Access
2542-01 (00:90:28:5a:21:6¢
s : g | lpdig o |Readony
E2242-01 (00:90:e8:21:b7:91)

% Modbus Device Group List
=1 DeviceGroup1
& [ Devicel
ﬁ TagGroupl

5-7



6

License Registration and Activation

Three versions of MX-AOPC UA Server are available. The trial version, which supports up to 30 connected
devices, can be installed and used for 30 days without registration. To use the free and paid versions you must
submit a license registration. Both free and paid versions can be used indefinitely, but the free version only
supports up to 30 connected devices. The three versions are summarized in the following table:

Version Connected Devices Run Time License File
Trial Up to 30 30 days Not Required
Free Up to 30 Unlimited Required
Paid Unlimited Unlimited Required

Take the following steps to register a license.

Step 1: Get the PC User Code from the MX-AOPC UA server’s configuration console by clicking Help - License.
For the paid version, you will need to purchase a registration code from your Moxa distributor. The Registration
Code can be found on the product label.

User Code u
User Code: 1613EB128766
License Status: Trial Version
Time Remaining: 11 days

MOXA®

MN: MX-ACPC UA Server

Rev.: 1.00

egistration Code: I" II

ccsasne [N

Made in Taiwan
PI/M: 3093018000021

TZADO10000001231

Step 2: Go to Moxa’s Software Licensing website (http://license.moxa.com) and log in with your Moxa account
and password, or apply for an account if this is your first visit to the site.

Step 3: On the Software Licensing website, navigate to Activate Your Software > Software Package >
MX-AOPC UA Server. Select Free Version and enter the User Code, or select Paid Version and enter both
the User Code and Registration Code.

MOXAN\

Home > Activate Your Software > Software Package > MX-AQOPC UA Server

®  Free Version
User Code:
Paid Version
Registration Code:
User Code:

Submit


http://license.moxa.com/

MX-AOPC UA Server License Registration and Activation

Step 4: Download the license file to a folder on your PC and unzip it.

Step 5: From MX-AOPC UA server’s configuration console, click Help > Licensing -> Add License File to add
the license file (.lic) to MX-AOPC UA Server.

& xorc us senc

File Edit WView Tools Runtime IHeIp

= = 0= Ei r] Server Help J_hég._n_cﬁ_l_n_a
LHE B . + =T

Licensing icense Info
- Active Device List About.. Add License File
EII| Modbus Device Group List

+--& J§ DeviceGroupl

Deactivate License

Step 6: After license activation is complete, go to Help > License Info to check the current license status.

e veco e

User Code: 1613EB128766

ii Complete license activation.
) License Status: Free Version

Max. Device Count: 30

o]

it

User Code: 1613EB128786

License Status: Paid Version
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Appendix

Port Usage

Port Type Usage

502 TCP Modbus Communication
53192 TCP Default UA Server Endpoint
9500 TCP Moxa AOPC protocol

9900 TCP Moxa AOPC protocol

Configuring DCOM Settings

If the OPC client only supports the OPC Data Access (DA) standard, you will need to configure DCOM settings.
Before launching MX-AOPC UA Server, configure the DCOM settings for your security policy.

NOTE If the OPC Client and Server software are installed on different servers, the DCOM, WORKGROUP, System
Account, and Password settings should be the same.

1. Go to the START menu and type dcomcnfg to activate the Component Services dialog box.

' See more results

|dcu:|mcr1fg| ¥ | | Shut down | ¥ |
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2. Right click My Computer under Console Root > Component Services > Computers, and click
Properties to open the My Computer Properties dialog box.

2 Component Services
. File Action View Window Help
e 2EIXECBE LIEDE

3 Conscle Reoot

7 : Q
4 #. Component Services

> [ Computers
' @ Event Viewer (Local)
B 5 Services (Local) Refresh all components
Wiew »
Properties

3. Click the COM Security tab and edit who is allowed by default to access, launch, or activate the

applications or objects.

My Computer Properties @

General I Options | Default Properties
Default Protocals | COMSecutty |  MSDTC

-,

I

Access Pemissions

You may edit who is allowed default access to applications. You may
also set limits on applications that determine their own pemissions.

Caution: Modifying access pemissions can affect the ability
_._I_\ of applications to start, connect, function and/or un
T secursly.

Edt Limis.. | | Edi Defaut.. |

Launch and Activation Permissions
fou may edit who is allowed by default to launch applications or

activate objects. You may also set limits on applications that
determine their own permissions.

Caution: Modifying launch and activation pemissions can
_._I_\ affect the ability of applications to start, connect, function
“ andsor mun securely.

| Edtlmis.. | | Edit Defaut..

Leam more about setting these properties.

0K || Cancel Apply
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4. Add Everyone, INTERACTIVE, NETWORK, and SYSTEM, and set Allow permission to all of these

groups.

Default Securty |

Group or user names:

52 SELF
S SYSTEM
52 NETWORK
S INTERACTIVE
| Add. |[ Bemove |
Pemissions for Everyone Allow Dermy
Local Access
Remote Access

Leam about access control and permissions

ok ][ Cancel |

) R )

Default Securty |

GI’OIJP ar user names:

52 5YSTEM
S NETWORK
82 Administrators (JE11WIN 7\ Administrators)
S INTERACTIVE
[ Add ] [ Remove ]
Permissions for Everyone Allow Dermy
Local Launch
Remote Launch
Local Activation [l
Remote Activation

Leam about access control and permissions

| ok || cancel
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5. Click the Default Properties tab and check if the settings are the same as shown in the screenshot below.

I

[¥]:Enable Distibuted COM on this computert

[ Enable COM Irtemet Services on this computer

Default Distibuted COM Communication Properties
The Authertication Level specifies security at the packet level.

Default Authentication Level:
Connect -

The impersonation level specifies whether applications can detemine
who is calling them, and whether the application can do operations
using the cliert’s identity.

Default Impersonation Level:
| Identify -

Securty for reference tracking can be provided if authentication is used
and that the default impersonation level is not anormmous.

[ Provide additional security for reference tracking

Leam more about setting these properties.

My Computer Properties @
Default Protocols |  COMSecuity | MSDTC |
General | Options | Default Properties

=
=

OK || Cancel A

-,

6. Click Yes when the following warning message appears.

-

DCOM Machine wide settings

You are about to medify machine wide DCOM settings, this will effect
i I‘x all the applications on the machine, some applications may not work

correctly as a result.Update DCOM settings?

Yes
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7. Go back to the Component Services dialog box, and right click MOXA_ACTIVE_OPC_SERVER under
Console Root > Component Services > Computers > My Computer > DCOM Config, and then click
Properties.

= =
= Component Services

#. File Action View Window Help

e« | 7EIXEc HE DIE=E
Microsoft WMI Provider Subsystem 5S¢ »
Microsoft. Aspnet.Snapin.AspMetMan;
MLICCTToMET

MMC Application Class
ModuleBrowselnfo
MOXA_ACTIVE_OPC_SERVER

5 I s I s S S S M W S

[ MSDAINITIALIZE View 3
s MzRdpSessionManage K Wik s

s METTS DecOhbj Class 5

: MAP Agent Service Properties

[» Map Elevated COM clas

. & NCLUA HEp

. & NDFAPI |

8. Click the General tab, and set the Authentication Level to Connect.

I )

MOXA_ACTIVE_OPC_SERVER Properties [ B (e

General | Location | Security I Endpoirts | Ident'rt'_f|

General properties of this DCOM application

Application Mame: MOXA_ACTIVE_OPC_SERVER
Application |D: {BcbfEabl-1bal-4a2h-8h52-554d 2594 3789}

Application Type: Local Service

Authentication Level: |Connect v]

Service Mame: MOXA_MM-ACOPC_UA_SERVER

Leam maore about getting these properties.

0K || Cancel || Aoply |
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9. Click the Security tab. You may either apply the default settings of Access, Launch, and Activation
Permissions to the MX-AOPC UA Server or customize the permission settings. If you would like to customize
the settings, make sure that Everyone, INTERACTIVE, NETWORK, and SYSTEM are added, and the
permission for these groups is set to Allow.

I )

MOXA_ACTIVE_OPC_SERVER Properties [ B (e

| General I Location | Security | Endpaoirts | Ident'rt'_f|

Launch and Activation Pemissions

@ Use Default

i) Customize Edit

Access Pemissions

@ Use Default

(™) Customize Edit

Corfiguration Permissions

(7 Use Default

Leam maore about getting these properties.

oK || cancel Apply
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10. Click the Identity tab and make sure The system account is selected. Now DCOM is ready to accept all
incoming connections.

MOXA_ACTIVE_OPC_SERVER Properties [ B (e
| General I Location | Security I Endpairts | Identity |
Which user account do you wart to use to run this application?
The interactive user.
The launching user.
(7 This user.
Uzer Browse
Fazsword
Conbirm pazsword:
@ The system account {services only).
Leam more about getting these properties.
| ok || Cancel Apply
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